Author Topic: Alternator Not Charging  (Read 277 times)

Offline 69mustang73mach1

  • Full Member
  • ***
  • Posts: 103
Alternator Not Charging
« on: June 05, 2017, 10:50:52 PM »
Hi Everyone,

The next saga on the 68 Mercury is all the lights now work.  The alternator will not charge.  It's showing 12.3 volts idling or when giving it gas.  I have the old original wiring in fair shape at best.  I have a new voltage regulator, starter relay, battery, battery cables, distributor, coil.  I have cleaned and grounds and still no change.  The dash has a light for alternator not charging.

Any thoughts or ideas would be appreciated.  Thanks Mark
Mark
1969 Ford Mustang Sportsroof, 390-4V
Dearborn built on Oct 31, 1968
1973 Ford Mustang Mach 1, 351C-4V
Dearborn built on Oct 31, 1972
1968 Mercury Park Lane Convertible, 428-4V
St Louis built on Apr 19, 1968

Offline mtinkham

  • Full Member
  • ***
  • Posts: 234
  • That'll be easy
Re: Alternator Not Charging
« Reply #1 on: June 06, 2017, 01:40:42 PM »
You can take the alternator to your local auto parts store and they can perform a bench test. Process of elimination...
1967 S-code Fastback, GT, 3-speed manual, Metuchen, Scheduled 04-21-1967 - Actual 04-25-1967

Offline 69mustang73mach1

  • Full Member
  • ***
  • Posts: 103
Re: Alternator Not Charging
« Reply #2 on: June 06, 2017, 11:10:04 PM »
Thanks for the suggestion.  The one that was on the car showed the same alternator reading as the one I just put on.  I took that one off my Mach 1 and it was charging just fine.  I can get it tested.  Thanks Mark
Mark
1969 Ford Mustang Sportsroof, 390-4V
Dearborn built on Oct 31, 1968
1973 Ford Mustang Mach 1, 351C-4V
Dearborn built on Oct 31, 1972
1968 Mercury Park Lane Convertible, 428-4V
St Louis built on Apr 19, 1968

Offline 69mustang73mach1

  • Full Member
  • ***
  • Posts: 103
Re: Alternator Not Charging
« Reply #3 on: July 02, 2017, 11:13:32 PM »
Update.  I took the used alternator and it came back bad.  So I purchased a new one from NAPA and installed it.  No change.  The dash light "Amps" stays on.  So I have  reman battery and took that in to have test.  It came back "battery good" under no load and load tests.

With the old alternator the readings were from 12.1v to 12.3v idling or higher idle.  With the new alternator  showed 12.5v - 12.7v.  So a slight improvement but not where it needs to be.

Any suggestions.  Thanks Mark       
Mark
1969 Ford Mustang Sportsroof, 390-4V
Dearborn built on Oct 31, 1968
1973 Ford Mustang Mach 1, 351C-4V
Dearborn built on Oct 31, 1972
1968 Mercury Park Lane Convertible, 428-4V
St Louis built on Apr 19, 1968

Offline jwc66k

  • Hero Member
  • *****
  • Posts: 3399
Re: Alternator Not Charging
« Reply #4 on: July 03, 2017, 01:24:15 AM »
Replace the regulator. A correctly functioning alternator at 2000 rpm will put out between 13 and 15 volts. Above 2000 rpm should be the same. At idle, you were probably reading the battery voltage.
Jim
I promise to be politically correct in all my posts to keep the BBBB from vociferating.

Offline 69mustang73mach1

  • Full Member
  • ***
  • Posts: 103
Re: Alternator Not Charging
« Reply #5 on: July 04, 2017, 12:12:26 AM »
Thanks Jim.  I have a new voltage regulator but it has went through 2 bad alternators.  I think it possible it got damaged. I will replace it and keep everyone updated.  Thanks Mark
Mark
1969 Ford Mustang Sportsroof, 390-4V
Dearborn built on Oct 31, 1968
1973 Ford Mustang Mach 1, 351C-4V
Dearborn built on Oct 31, 1972
1968 Mercury Park Lane Convertible, 428-4V
St Louis built on Apr 19, 1968

Offline 69mustang73mach1

  • Full Member
  • ***
  • Posts: 103
Re: Alternator Not Charging
« Reply #6 on: July 04, 2017, 07:57:47 PM »
Success!!! Installed a new voltage regulator and everything is good. Dash "Amps" light finally went out and the battery showed 14.3 volts.

Thank to all the great advice. Mark
Mark
1969 Ford Mustang Sportsroof, 390-4V
Dearborn built on Oct 31, 1968
1973 Ford Mustang Mach 1, 351C-4V
Dearborn built on Oct 31, 1972
1968 Mercury Park Lane Convertible, 428-4V
St Louis built on Apr 19, 1968